RFSoC2x2 Doesn't Show Up In Hardware Manager


I am trying to use ILAs to debug some things on the RFSoC2x2 (Running PYNQv2.6) and I can’t get it to show up in the Vivado hardware manager? I have followed the same connection and setup procedure for the ZCU111 and that works–I can see the device connected to the hardware server and interact with the debug cores. When I plug the ZCU111 into my Linux (Ubuntu 18.04 LTS) machine, it shows up as something reasonable “Xilinx MPSoC ZCU111 Eval Kit”. When I plug the RFSoC2x2 in, it shows up as the more cryptic “Dual RS232-HS”.

I also have a Windows machine (running Windows 10) I tried this on. When I plug the 2x2 into the windows machine, I see two new USB devices: USB Serial Converter A and USB Serial Converter B. Both have this concerning “Device requires further installation” message:

Both the Windows and Linux Machines have Vivado 2020.2 and Vivado 2021.1 installed and I have tried both hardware servers (2020.2 and 2021.1) and both boards and I consistently see the ZCU111 works and the RFSoC2x2 does not. On the Linux machine, I explicitly installed the cable drivers in <Vivado_Install_Directory>/data/xicom/cable_drivers/lin64/install_script/install_drivers/ for both Vivado versions. On the Windows machine, I downloaded the cable drivers along with the Hardware Server. If anyone has any tips or tricks for getting the RFSoC2x2 to show up in Hardware Manager I would greatly appreciate it!

1 Like

Hi Jenny, do you have an external JTAG programmer that you can connect to the J8 header?
E.g. Platform Cable USB II or XUP USB-JTAG Programming Cable - Digilent
The EEPROM on the board is blank so the USB-JTAG functionality is not available.



I do have one! I will give it a try and report back. Thank you!

Update: The Platform Cable USB II is working just great! Plugged it into the J8 header and now I can connect to debug cores on the 2x2. I’d be interested to know if it’s possible to use this device to program the EEPROM to add USB-JTAG functionality to this board?

A post was split to a new topic: Trying to program RFSoC2x2 using Digilent – Start Smart, Build Brilliant