Trying to program RFSoC2x2 using XUP USB-JTAG Programming Cable

Hi, I am trying to program RFSoC2x2 using Digilent – Start Smart, Build Brilliant. per your suggestion but I can’t still detect board in hardware manager in Vivado. I am using Vivado 2020.1.1 on Windows 10 and tried to install cable drivers for the same. Is there any specific procedure for the installation of Cable drivers? I ran through many threads on xilinx as well as digilent forum threads discussing these issues but nothing worked for me. Can you please tell me is there any compatibility issue of OS and Vivado version with XUP USB-JTAG programming cable? If yes, what version of vivado software and OS supports this programmer?

The cable drivers are an installable option which you install Vivado. If you followed the other forums I’m assuming you found instructions to install manually.

Which cable are you using and which port did you connect to? (I don’t know what product you are referring to in that link.
Does the board work correctly apart from the programming issue?


I figured out the solution. I am using XUP USB-JTAG programming cable (XUP USB-JTAG Programming Cable - Digilent) to program the device. It seems like cable comes without drivers and the install script that Xilinx runs as part of cable driver installation does not work correctly. You have to install those drivers manually. I followed this thread- Does XUP USB Jtag work with vivado 2018.1 - Other - Digilent Forum and it worked for me on windows 10 for Vivado 2020.1.1. Thanks.

1 Like

FYI, you should be able to open a JTAG connection without additional hardware (XUP USB-JTAG Programming Cable - Digilent). The issue is that the EEPROM for the micro FTDI interface on the board is not programmed to allow for this capability. I don’t know where the oversight for this lies, but I would guess some of the EEPROMs on the boards are programmed correctly and some aren’t.