PYNQ: PYTHON PRODUCTIVITY

DPU-PYNQ not installing properly on Ultra96-V2

Hello fellow PYNQ users, I am trying to download DPU-PYNQ on my Ultra96-V2 board but I seem to be running into a bit of trouble. I have been following this guide (DPU-PYNQ now available for ZU+ and RFSoC devices) and after reinstalling pynq 2.5.1 onto the board, I am stuck on the “make” step of the tutorial with the following errors:

Thank you for any kind assistance!

Regards,
Jacky76

Hi, It looks like an internet connectivity problem to me. If you are not already using one I would highly recommend a USB to Ethernet adapter connected to a wired connection vs onboard wifi.

Using a wired connection I just ran through the install a few weeks ago with no issues. I followed the instructions here (which does take a similar approach as to what you said you followed):

Hi there, thank you so much for your reply! Great to know that an adapter is a plausible solution to this problem but before I purchase any, is there any recommended adapter you would recommend? I’ll prefer avoiding the risk of a adapter that is not compatible with the board as I’ve experienced some similar events before. Also, would there be any configuration needed to interface the ethernet adapter or is it more or less plug and use?

So sorry for any inconveniences caused!

Regards,
Jacky76

It is plug and play. I don’t have an exhaustive list but I have personally used successfully the following:

Anker USB 3.0, https://www.amazon.com/gp/product/B00PC0H9IE/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

This tp-link should also work: https://www.amazon.com/gp/product/B00YUU3KC6/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

I have the tp-link also but I can’t remember if I’ve used it on the U96. I cannot try it out at the moment.

Good luck!

Hi @pynqzen I’ve gotten a ethernet adapter recently and tried to run the whole process once more but the error still appears.


I found a weblink on the error I had:

but I seem to be getting another error still after following the weblink.


Any ideas?

Regards,
Jacky76

Hi Jacky,

Looks like you tried to pick-up from where you left off from the other issue? Clean up from before by removing the directory or start with a fresh PYNQ SD image. Those are my suggestions.

Kind regards