Voila 404 not found

In trying to get interactive plots working in Voila i’ve managed to get to the stage now that when I try to open a Voila I get a 404 not found page rather than the dashboard.

I think I may have caused this by updating some packages trying to get interactive plots working in Voila as mentioned. I think it happened after updating jupyterlab and ipympl using pip. I now have version ipympl = 0.9.1
jupyterlab = 3.4.3

I guess I could try to roll these back but just wondered if anyone else had seen the 404 error and knew what was causing it?

Running ‘jupyter serverextension list’ gave this which looks interesting:


Hi @adi8v,

Can you provide a bit more information?

What board are you using? What PYNQ SD Card image version?
If the spectrum analyzer is available for your board, did you try to launch the Voila dashboard?



I guess you are trying to follow this link:

Notice that 2.6 is not same as 2.7. So make sure the packages are good and aligned.

Hi @marioruiz
I’m using a ZCU216 with a PYNQ image built from:

which is 2.7 by the looks of things.

I’ve had voila working but coudn’t get interactive plots to display in voila (although they worked in the notebook). In voila I got a message about javascript being disabled. Following a few posts elsewhere I applied some updates as above and that’s when voila started giving me the 404 error.

Hi @briansune
I followed this:

Not much to it! But I agree that it sounds like some packages might be now out of alignment.
I can always go back to my base image if I can’t recover it.

Is there a guide similar to the one you linked for 2.7 and what package versions should be used? Or is that information available elsewhere?

Just a short Google:

Sure that it is workable and you really need to try out the similar steps on the 2.6 version link.
And make sure you do use the netbook terminal to do so as this is redirecting to the correct environment.

Hi @briansune
I’m not sure why you’ve linked that page.
Good point on the environment though. If I start a terminal from a jupyter notebook, does that set up the environment or do I still need to run /etc/profile.d/pynq_venv.sh?
The console doesn’t show the environment at the prompt unless I run that shell script.


First I enclosed that link is because that example do plot successfully on PYNQ 2.7
Which so this is sure it can be done and should be done without major difficulties.

Second the notebook can either run command by adding ! at the front or open a terminal.
Both terminal or notebook script already invoking the virtual environment of the Python of the PYNQ that had installed on so unless you know what you are doing always install or modify packages on that environment otherwise problem will occur easily.

Hi @briansune
My problem is not with plotting, it’s with interactive plotting. I have re-flashed my base image and i’m back up an running. Interactive plots don’t work. I think it’s best if I post this problem in a new thread.


I am sure I am not referring to generic python plot here but make sure you clear out first.
From my link you can clearly see that it is a interactive plot on the GIF.
And as @marioruiz had mentioned in the other post that you open up.
Same library is using aka sdr_plots.py
import plotly.graph_objs as go

So I had no idea why you cannot see that example useful and as someone already provide a setup script for referencing as well.