ZCU216 ethernet connection problem

I am a beginner to RFSOC ZCU216
I used the image file PYNQ v2.7posted here The RFSoC Book and Design Examples for the ZCU208 & ZCU216 Development Boards and burn the image file to a formatted SD card
Now I can connect to the board by the serial port but it run out of some error messages such as fail to start snap daemon
and I can’t connect to the board through the ethernet( after setting my computer IP address 192.168.2.xxx
I also try to edit the eth0 file to modify the default IP but it doesn’t work
what should I do?
The Ethernet setting is below:

Screenshot 2024-05-14 232357


Hi @pynqishard,

Welcome to the PYNQ community.

As you can connect by serial to the board, can you try to see what IP is being assigned to the interface?

ifconfig -a

If there is no IP assigned, you may need to assign it manually.


Below is the result when I enter the ifconfig -a

I have already manually assigned IP eth0 and after I manually assigned IP, I can connect to Jupyter Notebool, but the ethernet terminal IP is not working.
I don’t actually sure if the error message below is related to the ethernet disconnection result

What do you mean? is this ssh?

yes, it is ssh.
how can i connect to the SSH?
thank you!

ssh pynq@

You may want to ping from your computer first. If you want a terminal, I would suggest you use JupyterLab and lunch a terminal from there.

When I tried to set up an SSH connection, it responded with “Connection refused.” Then, I used the ping command to test and successfully received response packets (though I’m not certain if this method is correct).

Apologies, the user is xilinx, so it should be

ssh xilinx@

However, it looks like that you’re trying to ssh/ping from the serial terminal (within) the board. You, need to use a terminal/powershell in your Windows machine. As I mentioned earlier, using the terminal via the JupyterLab should be the easiest way.


So I can connect to and use the Jupyterlab to ssh/ping ,is my understanding correct?
Or I should use my windows machine and open the jupyterlab to ping/ssh
Thank you!

Mario Ruiz via PYNQ <notifications@pynq1.discoursemail.com>於 2024年5月15日 週三,下午9:36寫道:

If you connect to JupyterLab, you are already in the board.

I am not understanding where do you want to ssh. Can you please clarify what is the source (machine) and the destination (system), not IP. In other words, what would you like to use ssh for.

So far, what you are trying is to ssh to the ZCU216 to itself.

sorry, i don’t clarify clearly.
I want to use MobaXterm to establish an SSH connection so that I can directly upload or edit some files or Python libraries. Currently, I am using a serial port to connect, but it is not visible and I don’t know how to upload files. My senior told me that I can connect to the board using MobaXterm SSH to after changing my computer’s IPv4 address to 192.168.2.xxx, and it actually works on the ZCU111.

Mario Ruiz via PYNQ <notifications@pynq1.discoursemail.com> 於 2024年5月15日 週三 下午10:08寫道:

In that case, you need to open an ssh session in MobaXterm, not reuse the serial one.

I would also suggest you explore JupyterLab to do this, you can copy files, edit files and more.

Thank you for your advice, but I still wonder if the ZCU216 supports the SSH connect.
I have tried many times to open an ssh session in mobaxterm but it always responds ‘connection refused’

It should support it, but I have not worked with this board.

Ok. Thank you very much for your help!