Access WIndows shared folder from PynQ Z2 & mount on it

I am trying to mount Windows 10 shared folder on PynQ Z2.

  • PYNQ SD card image v3.0.1, PYNQ Z2 Board

  • Kernal version:
    root@pynq:/home/xilinx# uname -r

  • Ubuntu details:
    PYNQ Linux, based on Ubuntu 22.04 pynq ttyPS0
    pynq login: xilinx (automatic login)
    Welcome to PYNQ Linux, based on Ubuntu 22.04 (GNU/Linux 5.15.19-xilinx-v2022.1 armv7l)
    Last login: SatPYNQ Linux, based on Ubuntu 22.04 pynq ttyPS0

I tried the following command:

root@pynq:/home/xilinx# sudo mount -t cifs -o user=user,vers=1.0,sec=ntlm // /mnt/windows
Password for user@//

Error Message:
mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

Debug steps tried:
I can ping, sftp & ssh to my Windows 10 Desktop from PynQ Z2 but not able to mount Windows shared folder on PynQ Z2 Ubuntu machine.

Thanks in advance.

1 Like

Try to use sockets.

1 Like