Composable Overlay not working on PYNQ-ZU

Moderator edit: moved to support category

I run 08_webcam_pipeline.ipynb on PYNQ_ZU
(http://localhost:9090/notebooks/composable-pipeline/custom_pipeline/08_webcam_pipeline.ipynb)

and I encounter below error:


why is this happen? and how can I fix it?

also, when I am running /composable-pipeline/custom_pipeline/09_mipi_pipeline.ipynb,
below error occurs…

Hi @ZI-YIN_Hong,

What PYNQ SD Card image are you using?
I would suggest you use the SD Card image 2.7 and follow the steps to install the composable overlay 1.0.0 https://github.com/Xilinx/PYNQ_Composable_Pipeline#install-composable-pipeline-on-your-board

The second error about the PCam 5C, did you connect the PCam 5C camera into the MIPI connector?

Mario

yes, the PYZQ version I’m using is 2.7 and I installed the composable overlay 1.0.0 as you said
(my board is PYNQ-ZU)
and I run PYNQ_Composable_Pipeline/08_webcam_pipeline.ipynb at main · Xilinx/PYNQ_Composable_Pipeline · GitHub

however I got below error:
cv2.error: OpenCV(4.2.0) …/modules/imgcodecs/src/loadsave.cpp:730: error: (-215:Assertion failed) !buf.empty() in function 'imdecode_'

1 Like

for the second question, yes I did connect the PCAM 5C camera
and I tried below notebook, and can run successfully

so, what is the problem here, is it because binary file “…/overlay/cv_dfx_4_pr.bit” I used has bugs,
(and it’s the old version? v1.0?)
or because that HDMIVideo function is deprecated.

and how can I probably fix it?

I am confused now, what notebook is not working? It seems that you could run the one with the MIPI camera but not the webcam.

so, what is the problem here, is it because binary file “…/overlay/ cv_dfx_4_pr.bit ” I used has bugs,
(and it’s the old version? v1.0?)

Not that I am aware of, however you do have the bitstream in two different places, did you copy this manually?

Mario

1 Like

I just fixed the MIPI notebook, so let’s forget about it.
(I use the URL in setup.py in your repo and download the newest overlay for PYNQ-ZU, and adjust my code, now it’s working properly, thanks for your code and resource. :slight_smile:)

However, I am running your notebook file for webcam, and it has below error, how can I fix it?

(Is it anything to do with my device?)

Is the webcam connected?
Did you try the notebooks in common that use the webcam?

1 Like

yes, it’s connected.
notebooks/common/usb_webcam.ipynb?
I just tried notebooks/common/usb_webcam.ipynb, and it was working properly.

Hi,

Can you please run these commands in a JupyterLab terminal and report the output?

lsusb

and

lsusb -t

What USB camera are you using?

Mario

webcam is on USB3.0 port3


I am not sure the webcam resolution, I will check later.
(are there any command line that I can check?)

Try to run this

v4l2-ctl --list-devices

My feeling is that the camera is not device 0, hence the error. But, we need to run this command to make sure

Hi @marioruiz :
So I can run the webcam notebook from your repo when I start-up the PYNQ-ZU board,

However, when I want to run it second time, it cause error at below cell

and seem that it can only run once successfully after starting-up the board,
what is the problem here?

Is the previous notebook still running?
Did you release the resources in the previous notebook?

Can you provide the exact steps to reproduce this?