PYNQ: PYTHON PRODUCTIVITY FOR ZYNQ

How I worked around startup issues with pynq z1

I wrote the image to the SD card, inserted it. But jupyter only showed a blank screen.
after seeing that the jupyter service crashed after some time, I decided to run it manually, only to get

 Exception: You must define the 'cookie_secret' setting in your application to use secure cookies

when connecting to the server.

Turns out, something was wrong with the config… after some googling I figured out it had to do with the tornado security. So to hack a fix for this, I changed
/home/root/.jupyter/jupyter_notebook_config.py
I uncommented the line and added the b’anything’
c.NotebookApp.cookie_secret = b’anything’
and tested if it worked by running
jupyter-lab --allow-root as root
This worked for me.

Thanks for sharing this.

Could you let us know the following?:

  • Which version of PYNQ are you using?
  • Which OS/Browser?
  • Which IP are you using to connect to PYNQ and is your board connected to the internet?

Cathal

I’m using pynq z1, connected with an ethernet-usb dongle to my windows 10 laptop
using a version 2.5 image from xilinx downloads.
Note that after changing the setting, I can connect normally from boot, and everything seems to work fine.

– Magnus