PYNQ: PYTHON PRODUCTIVITY

How to use XRFdc_IntrClr in PYNQ

Hi,

I am using zcu111 board and I am trying to set the DAC interpolation factor using Pynq.
According to pg269 rf-data-converter manual (page 200) ,

“Dynamic change in interpolation has an impact on the block throughput. The AXI4-Stream clock
rate can be dynamically changed to account for this change of throughput. In non-MTS mode,
the recommended procedure is to turn off the FIFO (Xrfdc_setupfifo), change the clock rate
(Xrfdc_SetfabClkOutDiv), clear the FIFO interrupt , and restart the FIFO
(Xrfdc_SetupFifo).”

How do I clear the FIFO interrupt?
I am using non-MTS mode and the steps I am following to change the interpolation factor are:

  1. turn off the fifo** : bit.usp_rf_data_converter_0.dac_tiles[0].SetupFIFO(False)

  2. change the clock rate** : bit.usp_rf_data_converter_0.dac_tiles[0].FabClkOutDiv=3

  3. change the interpolation factor: bit.usp_rf_data_converter_0.dac_tiles[0].blocks[0].InterpolationFactor=2

  4. restart the fifo** : bit.usp_rf_data_converter_0.dac_tiles[0].SetupFIFO(False)

I would like to know how I clear the fifo interrupt using PYNQ.