No module named 'pynq.overlays.base' after updating Pynq version

Hi, I am using the RFSoc2x2 with the SD card that came with it. I am very new to PYNQ and FPGAs.

I ran some of the example Jupyter Notebooks, and there were no errors. I updated pynq to version 2.7 from 2.6 using “pip3 install --upgrade pynq==2.7”, and now I am getting “No module named ‘pynq.overlays.base’” on line “from pynq.overlays.base import BaseOverlay”. I reverted back to pynq 2.6 but still the same issue.

Did updating the pynq version delete the base overlay, or am I doing something wrong? Will I need to rebuild the base overlay or download another SD card image?

Thanks for the help.

Hi @Somu,

Welcome to the PYNQ community.

You cannot update the pynq package directly from the board. You need to get a new SD card image with the version you would like to use. PYNQ supported boards and PYNQ pre-built images | PYNQ


I see. Thank you for the help.

In the pynq github, it says that "To update your PYNQ SD card to the latest pynq package, you can run the following command from a terminal connected to your board: sudo pip3 install --upgrade --upgrade-strategy only-if-needed pynq.

Is this incorrect, or am I missing something?


Good catch, this is not correct for major version changes.

In particular, from 2.6 to 2.7, we started using venv so the setup is different. I suggest you burn a SD card with the latest PYNQ image for your board.

Okay, Thank You!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.