RFsoc2x2 randomly disconnects and boots up less

Hello. I am using the RFSoc2x2 with PYNQ 3.0.1. I get the flashing white leds after a successful boot. Everything works fine: I can connect to Jupyter, open serial, ssh, etc. However, soon after, I get a “USB device not recognized” popup on my computer, and I can no longer connect to the board. Sometimes it happens after a couple seconds while other times it takes a few minutes. I redownloaded PYNQ 3.0.1 onto the card, but the same thing happens. It has been working without issues for the past two weeks until yesterday, so I am not sure what is the issue as I didn’t do anything.

Also, I’ve noticed recently that the board boots up successfully much, much less. I usually wait a couple minutes for the white leds, and if they don’t turn on, I restart the board. Sometimes I have to do this multiple times before the board finally boots up.

Thanks for the help!

Try use a different SD card. SD cards can be unreliable. I try to use branded cards for industrial use.


I did try another SD card, but nothing changed. Both SD cards were opened ~1-2 weeks ago, so I don’t think they are the issue.

Can you connect a terminal to the board, and check if any error message is printed before it crashes, especially during boot?


I’ve been trying to boot it up for the past half hour, and it just now booted successfully. I connected to the board via Putty. When the USB crashed, all it says is “Error reading from Serial Device”. Nothing is printed to the terminal.

I tried redownloading PYNQ 3.0.1 again but still the same issue. The USB shows up in Device Manager and the Ethernet shows up in Network Connections until I get the error after which they both disappear.

Can you contact the board vendor?


I have contacted the vendor, and they told me to contact Xilinx who has not answered yet.

Since then, the boot issue seems to have fixed itself. If I wait about 20-30 mins after turning off the board, it usually boots up properly, and the white leds flash. However, the board still disconnects, but now, it does it pretty consistently after about 20ish seconds. I have not been able to successfully connect to the board in the past week.