PYNQ: PYTHON PRODUCTIVITY

Pynq Z2 fails to boot

Hello everyone. We bought a bunch of Pynq-Z2 boards kits. Two of them get stuck when booting lighting up the RED Led (CR8). I looked at related threads and tried a few things:

  • Ruling out power issues (micro usb cable): I tried using a different cable, and different USBs. The thing is, we have more boards and the other works using these USB ports.
  • Checking jumpers (power and SD jumper). They are both right.
  • Checking the SD card. I used other SD cards for the other boards (that were successful) but they don’t work in these two boards.
  • Because of one discussion in the forum, I also downloaded the 2.4 image and tried. It works in the good boards but don’t work in these two.
  • I tried looking at the serial console and connecting through the Ethernet cable. The serial console gives no output (nothing) and the Ethernet does not connect (I guess the ssh service does not even start).

I am running out of ideas. Could anyone help? Thanks.

Can you try wall power instead of the micro usb power?

Hi Rock. Sorry, I forgot to mention that.
Yes, I already tried it too. It didn’t work (I also changed the power jumper to the REG position).
Same behavior, it got stuck at the red LED, and nothing comes out from the serial terminal.
I’m thinking it is a hardware failure

Seems to be a HW failure. Can you contact place you purchased?

Cathal