Unable to connect to RFsoc 2x2 board

PYNQ version : [v3.0.1]
Board name : RFSoC 2x2

Hi,

Up until recently, our RFsoc 2x2 was working just fine. Suddenly it no longer works. Specifically, from the LEDs near the power switch D38 (1V2L), D39 (1V2S), D44 (RF), and D46 (SYZ) are not on. The last one is expected to be off.

From the LEDs next to JTAG, D1 (DONE) is off, D2 (ERRO) is flashing red, and D5 (INIT) is red.

Something similar has happened before, and was fixed simply flashing an image on a new SD card. This time around, after plugging the SD card into a windows machine, it prompted for “repair” which did not work. Re-flashing the same, and new, SD cards with v3.0.1, v2.7, or v2.6 has not worked.

I have tried connecting to the RFsoc serially with a linux machine both with a micro-USB2.0 and the 3.0 connection and the , and am faces with a blank terminal. It goes without saying, but I cannot connect through ethernet either. What can I do to diagnose the problem? Is there anything else I should be checking/doing?

Thanks,
Zack

I’ll reply directly to you.

Cathal

Hey Cathal,

Yes, I am still facing the same issue. I recently thought it might be because i used rufus to write the disk to the sd card, but we also tried using a mac with the instructions on the wiki to write to the card and that didn’t seem to be what was wrong.

How do you recommend we proceed?

Hey Cathal,

Do you have any recommended steps I can take to diagnose the issue?

Zack