RFSoC 4x2 does not boot anymore

Started up my RFSoC 4x2 with PYNQ 3.0.1 as received without problem. Both USB and Ethernet worked properly. Also installed QICK and tested functionality of the board, everything ok.
Once in a while I lost connecetion to the board which I attributed to the local Ethernet. A reboot re-established connection. However, at some point the board got stuck in the boot process:

  • the red USB fault LEDs do not turn off, and the display stays dark
  • with the Ethernet cable plugged the blue LED stays on
  • with the USB cable plugged, the COM port is not appearing in the device manager as it should
    Used another SD card with v3.0.1, same result.

After about a week I switched the board on again, an it booted correctly !!?? It connected to the internet and to the PC via USB, with both SD cards. After a few hours working the conncetion broke again and I had to reboot - and the boot process stuck agian (see above). Since then the board has never booted again.
Has anyone had similar experiences and has an idea how to proceed?
Seems like a serious hardware problem to me.

Hi Patrick,

I have not had problems with my 4x2 but I have a few suggestions / things to try. My first thought would have been to re-flash the SD card. If you use a program like Balena Etcher it will verify the flashed image and I recommend doing that because I have seen it catch errors. You could also rule out the SD card issue if you have an SD card that you know boots a different 4x2.

If it’s an issue with power, the power status LEDs should give you some insight. Here’s what mine looks like after booting from an SD card and programming the LMK / LMX clock chips for the RFDC. Any chance you’re using an off brand power supply? If so, try the one that came with the 4x2.

Beyond that, it might be helpful to see if you can boot the board from JTAG. You’ll have to have something like the Xilinx Platform Cable USB II to plug into the JTAG header and you’ll have to flick the switch near the SD card to boot from JTAG. You should be able to open the Vivado hardware manager, connect to the board and see the FPGA and ARM core under “Hardware”

Here’s what my board LEDs look like when I boot from JTAG but don’t load any overlay:

Hope this helps!


Thank you Jenny for your suggestions!
I used the Balena etcher to flash an additional SD card. Actually both, the one supplied with the board and the new one were initially able to boot the board, but not anymore. So I would rule out an SD issue.
The power supply that came with the board delivers the rated voltage and the corresponding LED are all green when powered.
Unfortunately I do not have the Xilinx Platform cable USB to check your suggestion.
Thanks, Patrick

Hi Patrick,

I would check your USB cable. Micro-USB cables are not all the same. Some are for charging only. It could even be damaged and causing a short to the board at worst case. An iPhone would just stop charging with a bad cable, but on these boards, it likely would just reboot the board. I have many failed USB cables that worked with a phone and then mysteriously no more.

I would recommend swapping micro-USB cables and power cycling your board. If you cannot get the USB console to appear to your PC either via TeraTerm, putty or other serial port tool, then I suspect some systemic error to the board, because this serial console is the easiest way to diagnose boot issues. Without it, we are a bit blind as it may hopefully show the smoking gun of what caused it to loose your network connection or why it is halting during boot.

The other alterative is JTAG that Jenny mentioned, but you do not necessarily need the programming pod. Your micro-USB cable also provides a JTAG interface too. Try using Vivado Hardware Manager and Auto-Connect to the board. It could at least give us some connection details but too much to write about for now. The SystemMonitor feature reports back voltage rails, temperature and if some power supply is failing perhaps the on-board ADCs would capture that detail.



Hi Nathan

Thank you for your help.
The fact is that the board worked perfectly well both via Ethernet and USB. From time to time there were dropouts in the connection but then at some point it would just not boot anymore. I replaced SD cards, cables, power supplies, nothing brought it back. I also can no longer get the USB port to appear on my PC.

Yesterday I did a final test and swapped my board with a colleague’s, i.e. I put my board into his setup (his power supply, Ethernet, SD card). No success.
It must be a hardware problem that I can’t fix. So I am trying to get a repair or a replacement.


Dear Patrick,
I am sorry to hear your board failed. You may also want to take a look at that USB/PROG micro-USB connector on the board. I have had a different board’s USB connector break a few solder points from the board causing my USB connection to fail. I prefer to use extender cables as much as possible now to avoid wear and tear on the eval board itself.
Please reach out to Real Digital. The contact info from the website is: contact@realdigital.org
(509) 432 7958

Let them know the situation and what diagnostics you have done so far and they will take it from there.


1 Like

Thank you Nathan.

I contacted Real Digital and told them about the problems in detail.
They are kind enough to replace my board without complaint.

Best wishes