PYNQ: PYTHON PRODUCTIVITY

SD Build for PYNQ-Z1 failed v2.6.2

I’m using a VM with Ubuntu v18.04.4, and Vitis & Petalinux 2020.1 to build the SD Image for PYNQ-Z1. I’m getting an error about an expat download not being found when crosstool-ng is running. I’ve also run into this issue when I tried to build on image_v2.6.0, image_2.7, and master.

Does anyone know how to get around this?

I’ve also discovered that there is the same error with strace, and newlib. In addition, there is a gcc error where the repository the tool tries to clone doesn’t exist, because it’s been moved somewhere else.

I’ve attached the log where it fails at the expat download.
build v2.6.2 error log.txt (144.1 KB)

This is known issue with crosstool-ng and versions of tools that don’t exist anymore due to security vulnerabilities. We’re looking at a remedying this in time for 2.7 but don’t have a solution for now. I’d strongly recommend using the pre-built board-agnostic images and starting the flow from there rather than rebuilding the whole thing from scratch.

Peter

1 Like

Thanks!