SSH via direct ethernet connection

Tried SSHing into Pynq via a direct ethernet connection. I followed the tutorials, and set a static IP address to my laptop in the same range as board.
Board –
Laptop –
Subnet mask –
Gateway – (also tried leaving this alone)

The problem is it takes forever to detect the device. After logging in, every command takes at least 20-25 seconds. And it automatically disconnects after a couple commands like ls or cd.

I’m suspecting this could still be some IP config issue. Any help?
PS: I verified my cable and adaptors are working perfectly by connecting to an actual router and verifying speeds. Didn’t fiddle around with DNS server IP addresses either. Also tried bridging the connections. Any insight is super appreciated

1 Like

Also found out that when I connect the board to a switch, and my laptop to the same switch, the same issue continues. However, the moment I attach an actual internet-carrying ethernet cable to the switch, then suddenly SSH and everything is as fast as expected. Internet bridge isn’t a necessity, right?

Okay, it so happens, that isn’t the IP of the board that was set previously.
I’m not sure what is going on; when I use the actual board’s IP (192.168.y.x) which I found out recently from a colleague, I’m able to get direct connection without needing a switch with actual internet also going into it.

If it helps: my WiFi gateway’s IP was around that range of 10.0.0.x – and we concluded perhaps there’s something going on here.