PYNQ: PYTHON PRODUCTIVITY FOR ZYNQ

Unable to connect using MAC Powerbook

I’m using a Ultra96 running Ubuntu 16.4. When I type in 192.168.2.99 or 192.168.1.3 on my Linux box everything works great!

Not so with my Mac Powerbook. I get nothing.

What is the driver called that performs this function on Linux and PCs? Has anyone had success using a powerbook?

Does the network interface come up on your Mac, and can you ping the board?

If so, it may be the browser and this issue:

Cathal

The USB connection uses the RNDIS protocol (similar to a number of android phones) which doesn’t appear to be supported natively on MacOS. A quick search turned up HoRNDIS as a possible optional but it is not something I’ve tried

Peter

I have tried HoRNDIS . It works well!

Dang and double dang. Loaded HoRNDIS as a binary, loaded and rebooted. No joy. Curious.

Naveen, did you include small animal sacrifices or the magical arts?

@FlashPackets

I did this in March 2019 briefly to test the USB Gadgets access from macOS (High Sierra).

By default, the File system Gadget and Serial port Gadget worked well, but the Ethernet Gadget did not come up.

In my macOS configuration, it required the installation of

Once installed and rebooted, I was able to ping 192.168.3.1 and to browse to the PYNQ Jupyter Notebook at that location as well.

Starting from macOS Sierra, the HoRNDIS kernel extension is supposed to have been installed, but several pages recommend reinstalling if it does not come up at once.

Just tested on PYNQ Version 2.4 image, Ubuntu 18.04
Here is the screenshot FYI:

Everything is working GREAT!

Thanks

1 Like