PYNQ: PYTHON PRODUCTIVITY

ZCU104 Internet Issue Continuation and Solution

I’m a new user so have limitation for posts. Hence a new post.

Continuing the discussion from Connecting to the internet - Zynq 104:

I have found the solution for this. The pynq image is based of the Ubuntu Distro. Ubuntu is slowly migrating to a new tool called Netplan for network configurations. Pynq images for Pynq Z2 and ZCU104 are capable of using it. That MIGHT be the case for the other images. I shall put the steps I did below.

  1. Try the advice by other people above
  2. If the issue does not resolve, discard all the changes
  3. Remove or Comment (#) DHCP configuration if set in
    /etc/network/interfaces.d/<interface-name>
  4. Follow Setting DNS Nameservers on Ubuntu Server in the link below. Note: A YAML file might have to be created if it does not exist
    Set DNS Nameservers on Ubuntu 18.04 Guide
  5. The above guide shows a static configuration. Set DHCP to yes and remove addresses field under it.
  6. The addresses field under nameserver can be set to any DNS nameserver address. Google’s DNS nameserver did not work for me so I switched to OpenDNS.
  7. Try wget <website-link>/index.html after completion. Request should be able to resolve and file is downloaded.

My netplan file from ZCU104

image

Note: The gateway4 field in my example is the address of a Ethernet adapter plugged in a Desktop PC to share Internet connection. Guides below

  1. Share Internet from Ubuntu PC
  2. Share Internet from Windows 10 PC

Do you think there should be a pull request on the main repo to fix this issue, or you think this is a good documentation to add in readthedocs?