Connect to board as shared drive

Hi Cathal,

I am new to this forum and pynq programming so the problem I have may be simply solved.
The answer you gave here about the samba connection does not work on our ZCU111 board.
I have followed the pynq image install instructions. I have connected the pynq card to the loacl network within our institute. I can access the jupyter and jupiyter lab portals which both work well with a couple of demonstrator projects. I have been able to download the repository files without problems.
When I try to connect from a windows machine I connect a new network drive calling it \pynq\xilinx. I enter \xilinx and xilinx for usr and passwrd. The backslash is needed so that the local segment name is not included by default (\domaint\xilinx).
I am informed that either the usr or the passwrd is wrong. Any ideas? Even our system manager has no idea why it should not work.

Do you just need to copy files to/from the board?
If you are using Jupyter Lab, you can drag and drop files in to the Jupyter Lab folder area to copy them to the board. You can also right click and download files from here. Would this work for you?

I’m not sure why you need the backslash. I don’t know much about this issue you are referring to (local segment name). Maybe this issues is related to your network setup?

If drag/drop in Jupyter lab isn’t a good option for you, can you let us know what version of PYNQ you are using with the board, and can you ping pynq and also the IP address? (This is a sanity check - if you can connect to Jupyter this should work)
Can you ssh to the board?
You can also use SFTP (e.g. WinSCP) or other ways to transfer files if Samba doesn’t work. The board is based on Ubuntu, so you should be able to use many ways to transfer files.

Edit: could there be another PYNQ board on your network where the username/password was changed?


Thanks for the reply. This has been really useful. I did not know about the copy paste in jupyterlab. Also the other possibilities are good options.
The backslash is the network setup and our system manager seems to think that it is not the problem here.
I have been able to ping pynq and the IP address ( we are using the dynamic IP address assigned by the network. It seems to work fine for jupyter etc.
I will try out the other options of file transfer you suggest. I am not aware of another board on the network nor changing the password. I could try changing the hostname.
Thanks anyway. Your advice has given me some more ideas to try. If I resolve the samba issue I will write back