Fail to rebuild PYNQ v2.6 base overlay - ZCU104

Hi, I followed Tutorial: Rebuilding the PYNQ base overlay (PYNQ v2.6) indeed to rebuild base overlay. I used “source ./build_bitstream.tcl” to build bitstream by myself.
After 2 hours building time, it showed error:
ERROR: [Common 17-70] Application Exception: Need an implemented design open to write bitstream. Aborting write_hw_platform…

And then I checked result:
.\PYNQ\boards\ZCU104\base\base\base.srcs\sources_1\bd\base\hw_handoff\base.hwh existed.
.\PYNQ\boards\ZCU104\base\base\base.runs\impl_1\base_wrapper.bit didn’t exist.

[My total steps]

  1. Opened Vivado 202.1
  2. “cd my_PYNQ_repository/boards/ZCU104/base” on Tcl console
  3. “source ./build_ip.tcl”
  4. “source ./build_bitstream.tcl”

Did I miss something?
Any help will be highly appreciated!

[Building Environment]
CentOS 7.7
Vivado 2020.1
PYNQ v2.6

PS. The attached file is the completed tcl console log.tcl_console_rebuild_baseoverlay.txt (809.0 KB)

1 Like

You need a license for the HDMI IP on the ZCU104.
See this post:



Dear Cathal:
Thanks for your reply quickly!
I tried to get the Evaluate IP for HDMI, which is according to the Vivado License Manager:

I’m not sure whether the IP License don’t appear on my Vivado automatically, because CANNOT see that in View License Status:

(I guess that the license doesn’t belong to Free Built-in Licenses.)

Have I successful to get the HDMI IP license and can run “source ./build_bitstream.tcl”?
Or I need to do anything else to activate that? Or I fail to get the license for my Vivado?

PS. I use Virtual Box to run Linux-CentOS.

For license questions, you may be better posting on the [Xilinx forums[(
It looks like you don’t have the license set up properly. You don’t have any liceses set up in ‘VIew License Status’.
Try check ‘Manage Licenses Search Paths’. You need the full path to your license file(s) here. If you have multiple licenses, separate them with a ;
C:\my\path\license.lic; 27000@myLicenseServer


1 Like

Download ZCU104 bsp 2020.1 and add to BOARDS/ZCU104 folder :slight_smile:

1 Like

Dear bartokon:
Thanks for your reply!
I’ve downloaded the ZCU104 BSP and put it into the same dir as build_bitstream.tcl:

Is it right? Or I need to rename the bsp file or else step?

Hmm I think, the project should builld… after you move .bsp one folder up :slight_smile:
Look at ZCU104.spec file:

ARCH_ZCU104 := aarch64
BSP_ZCU104 := xilinx-zcu104-v2020.1-final.bsp <---------- this should point to bsp
BITSTREAM_ZCU104 := base/base.bit

STAGE4_PACKAGES_ZCU104 := xrt pynq ethernet sensorconf boot_leds

1 Like

Dear Cathal:
Thanks for your hint!
I found I don’t put the .lic file received from Xilinx by mail into designated directory.
After I put it into “$HOME/.Xilinx/”, the View License Status could detect it!
And then I rebuild it, and get the base_wrapper.bit successfully!
Replace base_wrapper.bit, base_wrapper.tcl & base.hwh on PYNQ for test, and the behavior is the same as original file!
Thanks a lot for your assist!!

Dear bartokon:
Thanks for your reply!
I’ve solved the question by providing the HDMI IP license to Vivado.
However, I still appreciate your suggestion a lot!