PYNQ: PYTHON PRODUCTIVITY

Getting started

Hi, I have a problem with getting started with PYNQ.

I’m trying to build my custom image (or any other image).

I have created folder in PYNQ/boards like this (password is root):
Minized.zip (2.2 MB)
It’s on ubuntu 18.04 https://1drv.ms/u/s!As37uPW_18jehTkymDK5EiuWbuC1?e=Y4C2d3 (I have just sourced setup_host and installed 2019.1 version of tools)

I have tried:
git clone https://github.com/Xilinx/PYNQ.git -b image_v2.5.4
and
git clone https://github.com/Xilinx/PYNQ.git -b v2.5.1

and nothing works :slightly_frowning_face:

I have ./build:
sudo ./setup_host.sh or sudo source setup_host.sh

I have entered sdbuild and type:
Preformatted textmake BOARDDIR=Minized
Preformatted textmake BOARDDIR=/home/bartek/PYNQ/boards/test
Preformatted textmake PREBUILT=/home/bartek/bionic.arm.2.5.img BOARDS=Minized
Still not working…
.
My goal is to create step by step tutorial for PYNQ, but I can’t create basic image for it :frowning:
Can someone help me create working custom image for PYNQ?
I don’t know what I’m doing wrong and I need some help :frowning:

Can somebody post here full commands that I need to do before creating for example PYNQ-Z1?
I will use it as reference design and try with my own.

Thanks for help.

This is weird. Right now I have 3 different PYNQ repos on my machine and only one is working. The working repo is in detached Head state unlike the rest. I think on that repo I have tried plain “make” command and that updated repositories, tried to rebuild all BOARDS and failed on ZCU because of license.

Next thing I have tried was from quick porting guide " ```
bash scripts/image_from_prebuilt.sh MinizedPynq Minized_Pynq.bsp arm bionic.arm.2.5.img;


Other repos are just git cloned -b image_v2.5.* and run
"bash scripts/image_from_prebuilt.sh MinizedPynq Minized_Pynq.bsp arm bionic.arm.2.5.img;" which fails on e2fsck /dev/loop*p*.

+ sudo chroot / e2fsck -y -f /dev/mapper/loop22p2
e2fsck 1.44.1 (24-Mar-2018)
e2fsck: No such file or directory while trying to open /dev/mapper/loop22p2
Possibly non-existent device?
Makefile:324: recipe for target '/home/bartek/Desktop/Minized_EMMC/Avnet/PYNQ/sdbuild/output/MinizedEMMCPynq-2.5.img' failed
make: *** [/home/bartek/Desktop/Minized_EMMC/Avnet/PYNQ/sdbuild/output/MinizedEMMCPynq-2.5.img] Error 8

I will try some variations of cloning and building projects with different repos and try to guess the working solution :\

There could be error with corrupted disk image/files. So the best solution is reboot machine, check disks and retry.

You should put Minized folder under some local path. For example, /home/bartek/boards. Then

make BOARDDIR=/home/bartek/boards

Since you have the .spec file inside Minized folder, that folder will get picked up by the make process.

Don’t confuse the PYNQ folder inside the sdbuild/build folder with your original PYNQ folder. The sdbuild/build/PYNQ is a temporary folder and it will get cleaned when you run make clean.