GitHub - strath-sdr/rfsoc_qpsk: PYNQ example of using the RFSoC as a QPSK

The university of Strath provided several examples. However, when I opened them in Simulink, System Generator doesn’t open!
If I delete their system generator and put the system generator from the Simulink library it opens correctly. However, when I put the right FPGA things, I face a lot of errors.
I run it with a different version of Matlab and Vivado, including the versions they suggested. This error exists for all examples.

Another issue is the path toward Matlab and then Vivado and Jupyter are unclear.
For example, if I wanna change the bit rate from 1000 to 2 Gbps, then assume passed all these difficulties make replicating their examples impossible!
Then, how updated the Vivado version of IP then how did I set up new my own design on Jupyter?

The education materials for using hardware are significantly insufficient. Also, for new people in this area, many key passes are missing.

Hi @mnaghshvarian,

I am sorry to hear that you are having issues with rebuilding the RFSoC-QPSK demonstration. I will try and help you progress as best as I can.

Can you describe the steps you are taking to open the System Generator designs? Here is a list of things I need to know:

  1. What operating system are you using to run System Generator?
  2. Are you using the correct version of Vivado and MATLAB? These should be Vivado 2020.2 and MATLAB R2020a.
  3. Is System Generator configured correctly? Have you executed the System Generator 2020.2 MATLAB Configurator in administrator/sudo mode and bound the tool to MATLAB R2020a?
  4. What specific System Generator model are you trying to open?
  5. Are you receiving an error when you try to open a model? What does this error report?
  6. Have you installed the RFSoC devices with your distribution of Vivado 2020.2?

The above should be enough to help me get started debugging your problem. Just to note, I ran tests on this repository today, and all is working as expected on our systems. At first glance, it appears you do not have something configured correctly.

Regards,
David.

3 Likes