PYNQ: PYTHON PRODUCTIVITY

Install python library on pynq board via putty terminal

Hi, I was trying to install library pyttxs(text to speech) via putty terminal on the PYNQ-Z2 board. This library I want to use for my project and is compatible with python 2 and python 3
I have run pip install pyttx3 command, it shows
-bash: pip: command not found. on the putty terminal

Then, I have run pip3 install pyttx3, it shows on terminal

Collecting pyttx3
Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by ‘NewConnectionError(’<urllib3.connection.VerifiedHTTPSConnection object at 0xb57c7cf0>: Failed to establish a new connection: [Errno -3] Temporary failure in name resolution’,)’: /simple/pyttx3/

This has happened with every python package or library I want to install. I have also tried to install theano package. Same problem occurs.

Please suggest how do I install python packages on pynq board.

Hi @Mohita_jaiswal,

Is your board connected to the Internet? Can you ping to a known server?

You should also install the package as root. For instance, sudo pip3 install pyttx3

Mario

yes, the board is connected to the internet. I have followed all the steps for setting up the pynq-z2 board.
ipython notebooks are working perfectly fine. But the only problem is with the installation of python packages.

I ping to pynq(hostname)

I have tried to install the package as root also. Not working. same error occurs.

Same issue in the installation of a package for root also.

From the board can you ping an external website? e.g. google.com

Cathal

No, when I ping an external website i.e google.com, it shows temporary failure in name resolution
What does it mean??

Please can you comment how is the board connected?,
E.g. Where is the Ethernet port connected to?

The problem is solved now.
Board is connected to router. Now, there is internet access via a network that allows python packages to be installed.

Untitled (1)

Thanks for the help!

1 Like