PYNQ: PYTHON PRODUCTIVITY

Jtag connection PYNQ-Z2

Hi,

I have a PYNQ-Z2 board. I know it works since with default image on shipped SD card it boots perfectly. I would like to use it without the whole overlay stuffs (at least for the moment). I am looking to develop my own overlay lib (if possible). Anyway I am not able to connect to the target when it comes to program it. I have downloaded all the BSPs and XDCs from ufficial repos. I know I have done pretty much everything (also installed FTDI drivers and check the usb interface is detected correctly). But both Vivado HLs and SDK keeps saying the cannot connect to the target (it complains it is not a valid target). My questions are: is it possible that I am using an old version of Vivado (ie 2016.4)? Does anybody tried to program the whole ZYNQ on PYNQ via SDK directly on a full custom design (no boot from SD/Quad-SPI/etc)? Thank you in advance

Yes, you can do this. You should just need to connect the USB cable.

HLS won’t connect directly to the board. SDK needs to connect to a project, so you may have something wrong with your setup.

The older Vivado version shouldn’t be an issue. Did you try download a bitstream, or even just connect to the board from hardware manager?

Cathal

1 Like

Thank you for your answer Cathal.

Yes that was the problem, I could not even connect the target/board from Hardware Manager… that lead me to think the problem was in the missing FTDI driver… Adding them did not solve because Vivado uses its own drivers (optional with the suite installation). I’ve just realized that apparently I’ve never used my laptop to program the zynq in the lab.

I am feeling a bit ashamed for such a silly topic… I hope at least it might help someone in the future!

Installing the Vivado Cable Drivers solved the issue. For more info see Vivado Design Suite UG (pick the one for your version) - Installing Cable Drivers chapter.

Paolo

1 Like

Great you figured this out, and please don’t feel bad! Thank you for posting back with the solution.

Cathal