PYNQ: PYTHON PRODUCTIVITY

PYNQ rootfs full

I burned a new PYNQ image and I am getting the following issue. The rootfs partition is full and I cannot copy anything on the device. You cannot even use the tab for autocompletion/
I tried doing the same for a ZCU104 board using a 32 GB SD card and I am getting the same issue there too.
Is there any workaround?

The programs included with the Ubuntu system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.

-bash: cannot create temp file for here-document: No space left on device
xilinx@pynq:~$ df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root       5.8G  5.8G     0 100% /
devtmpfs        1.9G     0  1.9G   0% /dev
tmpfs           2.0G     0  2.0G   0% /dev/shm
tmpfs           2.0G  1.5M  2.0G   1% /run
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           2.0G     0  2.0G   0% /sys/fs/cgroup
tmpfs           396M     0  396M   0% /run/user/0
tmpfs           396M     0  396M   0% /run/user/1000
xilinx@pynq:~$ ls /dev

The root filesystem should automatically expand to fill up the entire SD card on first boot.

The spare space is taken up by a swap partition so you can get at least some space back by running the following commands as root

swapoff /var/swap
rm /var/swap

Exactly why the filesystem hasn’t been reseized I don’t know. If you look in /etc/environment is there a line that says RESIZED=1. If so delete it and try restarting the board to have another go. You can also use the command systemctl status resizefs to see if there are any error messages that have arisen.

Peter

I resolved it by using Gparted to resize the root partition. This only worked on one 16GB SD card however.
It did not work on a second 32Gb card.

I also tried to edit the /etc/environment file and deleted the RESIZED line. That did not work.

No error messages were seen with systemctl.
PYNQ was generated by using a BSP and the rootfs for aarch64.