PYNQ: PYTHON PRODUCTIVITY

PYNQ Z1; Done and LD13 are on but it seems like both is stuck

PYNQ Z1 doesn’t boot successfully anymore. It was doing fine the last time I used it.
Blue LD4 & LD5 LEDs and four Yellow/Green LD0-LD3 LEDs do not flash simultaneously. The Blue LD4-LD5 LEDs Yellow/Green LD0-LD3 LEDs are not turning on. What is the problem here and how to fix it ?

microSD card is from Toshiba.
The board and my MacBook are connected directly.

Have you tried reflashing the micro SD card with the latest PYNQ version?
or using a different micro SD? http://www.pynq.io/board.html

Can you capture the output of the serial terminal? https://pynq.readthedocs.io/en/v2.5.1/getting_started/pynq_z1_setup.html#opening-a-usb-serial-terminal

@marioruiz Hi, I haven’t tried reflashing the microsd but I can capture the output of the serial terminal. I can log into xilinx@pynq: . It was working fine when I used last time. I can login to Jupyter. I have updated the date manually in Xilinx terminal.

There is a startup script that runs to flash the LEDs. Perhaps you modified this, of for some reason it is not running or has been disabled.
See info here if you want to try and check this:

If you can log in to Jupyter and everything else seems to be working, then I wouldn’t be too concerned about the LEDs not flashing if you don’t see any other issues.

If you have other issues, re-flashing the SD card may be the best option as @marioruiz suggested.

Cathal

@cathalmccabe Thank you, I will try this.