PYNQ: PYTHON PRODUCTIVITY

Unable to boot from SD

I’m unsure if this is a hardware of software problem. I’ve already contacted the vendor.

I just got my Pynq z2 board. I followed the instructions at https://pynq.readthedocs.io/en/latest/getting_started/pynq_z2_setup.html. When I get to the step where I power it on, all I get is the power light.

I verified I have SD card boot selected. If I remove the jumper completely then it seems to run a default program and cycles LED4 and 5 through blue, green and red. If I put the jumper back, it goes back to only the power light.

I’ve tried two SD cards and reflashed the software twice as well.

Any other common first mistakes I can check for?

edit: When I boot it with the jumper on SD, the reset and program buttons appear to do nothing. If I boot it with the jumper completely off, the reset button will cause the LED sequence to reload, and the program button will turn off the LEDs including the done led leaving only the power led.

Can you connect a USB cable and open a terminal?
https://pynq.readthedocs.io/en/v2.5.1/getting_started/pynq_z2_setup.html#opening-a-usb-serial-terminal

This would show you the boot process and indicate if it is getting stuck somewhere.

Cathal

Thank you for your response.

While the issue was occurring there was no console output available.

I ended up downloading the version 2.4 image and flashing that instead of using 2.5. 2.4 worked the first time and I haven’t had any known issues with it yet.