RFSoC 4x2: USB host and USB Device NOT working


By all means, I tried all different ways including following link:

Unfortunately none of the USB ports are functional.
the board is not able to detect any connected USB key or USB camera. lsblk, lsusb in terminal doesn’t show any connected device. here is lsusb while USB key and USB camera are connected

I tried the latest version of PYNQ, PYNQ V.3.0.1 and none of the USB ports worked.
The board is new and I downloaded the PYNQ image from following link:

Many thanks!

1 Like

I have the same problem and cannot mount any USB devices. My RFSoC 4x2 is also new and I’ve installed the latest version of PYNQ. lsusb doesn’t show any devices connected!

We are working in research lab, and we received new 4x2 boards. They all had the same problem of being unable to detect the USB driver device leading to all USB port being unreadable. We are still able to communicate using the UART serial port. Below is the error message we get during Linux boot phase. We test on the latest version of PYNQ 3.0.1

The first batch of 4x2 board we received all have functioning USB port with the latest PYNQ version.
![log-linux-usb-hub-working-previous-rfsoc|690x103 (upload://6VwoJ7ednsyL0bOG7UTfHYKR9bX.png)

After looking at the USB hub ICs we noticed a difference between the first and latest boards batch.
Smart hub USB5742 we suspect that there might be a difference in versions: A001 is on the functioning board and series B101 is on all of the new, none functioning, boards. Hence, we believe, that the PYNQ images are not able to support the current iteration 4x2 hardware.

This interface is very important for our projects, we would very appreciate help fixing it.



here is the result of
dmesg | grep usb

the error is:
[ 5.780286] usb 1-1: device descriptor read/64, error -71
[ 6.020285] usb 1-1: device descriptor read/64, error -71
[ 6.260254] usb 1-1: new high-speed USB device number 3 using xhci-hcd
[ 6.392293] usb 1-1: device descriptor read/64, error -71
[ 6.649237] usb 1-1: device descriptor read/64, error -71
[ 6.760457] usb usb1-port1: attempt power cycle
[ 7.180254] usb 1-1: new high-speed USB device number 4 using xhci-hcd
[ 7.186875] usb 1-1: Device not responding to setup address.
[ 7.400294] usb 1-1: Device not responding to setup address.
[ 7.612247] usb 1-1: device not accepting address 4, error -71
[ 7.748257] usb 1-1: new high-speed USB device number 5 using xhci-hcd
[ 7.754883] usb 1-1: Device not responding to setup address.
[ 7.968308] usb 1-1: Device not responding to setup address.
[ 8.184250] usb 1-1: device not accepting address 5, error -71
[ 8.190709] usb usb1-port1: unable to enumerate USB device

@marioruiz @cathalmccabe , could you please help us?
Your help is highly appreciated

Hey Jeremy and Mohammad Hossein,
Could you find any solution to this problem?
We also got a new board, which seems its USB port doesn’t work.

Hi darinoos47
Thanks for sharing with us.

The obvious point is that in the production line, they replaced the USB PHY:
USB PHY 5742 A001: works and is functional.

USB PHY 5742 B101: doesn’t work and is NOT functional.

There are multiple reasons that can cause this issue:

(Maybe) The new USB PHY is slightly different from the previous PHY, thus it is possible that the provided power or clock is not suitable for it.
(Maybe) there is no porvided clock, In this case we need to measure the provided power and clock for the PHY.
(Maybe)The new USB PHY needs to be programmed.

I did the following test that maybe its results can help to solve this problem:
I wrote PYNQ V.2.7 in SD Card and connected the board to the USB.2 of the host computer. Then the board is recognized with the host computer(IP address However, still none of the USB ports on the board works and “dmesg” shows the similar bug.

It gives this idea that if one can create a PYNQ image with USB.2, maybe it can resolve the issue. To do this, first we need to create a new base bitstream (in Vivado) while the USBs peripherals are set up as the USB2. And then create the custom PYNQ image with the generated bitstream.

If this issue is not resolved, then the real digital needs to recall all the boards and replace the USB PHY.


1 Like


This could be OTP is not updated.
Do the board got any SPI flash near the USB hub?
If not then this is sure both OTP and driver is not aligning and causing such abnormal behavior,
This is similar to REATEK chip.


Many thanks @briansune
I checked and SPI port of USB PHY is connected, but I’m not able to determine is connected to where exactly. Perhaps is connected to I/O ports of FPGA.

Do you know how to program the PHY USB? Or how we can align the OTP and driver?

kind Regards


From a short review the schematic had no node on those pin. And only reset is connected.

This is just a pure logical guess as you mentioned the old chip works.
For the OTP please refer back to Microchip Technology Datasheet and documents.
As chip do support OEM OTP servicing.

As for the driver itself unless there are github developer release or Microchip itself provided otherwise there are zero hope to make that happen experienced on REALTEK as well.

Btw, do both USB3320 and PS GTX turned on or it is purely putting old SD image to new board with that new chip ID? If so then it is very sure that the case =[