PYNQ: PYTHON PRODUCTIVITY

Trying to get PYNQ-Z2 run wirelessly from my laptop to use Jupyter and had PuTTY error issues opening a USB serial terminal

Hi,

I currently have issues opening a USB Serial Terminal

I tried to follow the following instructions:

https://pynq.readthedocs.io/en/v2.5.1/getting_started/terminal.html


The above .html doc had a PuTTY link which I downloaded :

MSI (windows installer) 64bit
putty-64bit-0.74-installer.msi

I then installed this PuTTY 64bit (my Windows 10 is 64bit) package file from the above link

Noticed there are also several other Alternative files listed. It stated that the installer package will provide versions of all of these (except PuTTYtel) but I can download standalone binaries one by one if I prefer.

The one listed within the alternative binary files :

puttytel.exe (a Telnet only client)
I also installed this 64-bit version & tried the same test here

ie followed the following instructions :

In the Windows Device Manager of the control panel.

  1. Open the Device Manager, expand the Ports menu
  2. Find the COM port for the USB Serial Port . e.g. COM5

The COM port for me showed COM3

  1. Open PuTTY

(I opened either PuTTY or PuTTYtel configuration)

Once PuTTY is open, enter the following settings:

  1. Select serial
  2. Enter the COM port number
    I entered COM3
  3. Enter the serial terminal settings (below)
  4. Click Open

Full terminal Settings:

  • 115200 baud
  • 8 data bits
  • 1 stop bit
  • No Parity
  • No Flow Control

Hit Enter in the terminal window to make sure you can see the command prompt:

—-
I had to select first category “Session”

Serial line: COM3
Speed: 115200

Then I selected category “Serial”

  • 115200 baud
  • 8 data bits
  • 1 stop bit
  • No Parity
  • No Flow Control

After I select ‘open’

Got:
PuTTY or PuTTtel error
Unable to open connection to COM3
Unable to open serial port

I checked the latest driver of Port (COM3) and it reported that the best drivers for my device are already installed.

I also tried disabling the COM3 port and re-enabled it few minutes later & rerun the test but for same PuTTY error as reported above.

Looks like I am stuck here not able to proceed to the next stage…

Any assistance to this matter will be appreciated.

Thanks,
Kevin

Are you sure Com3 is correct?
You can try disconnect the USB cable, see if it disappears, and then reconnect and check if it reappears.

Cathal

It’s a USB Wifi dongle. Plugged that onto the PYNQ-Z2 board USB host. You are right. COM3 does not look right. That was the COM’s port only listed on the ports list when I followed setting up the USB Wifi instructions from another post. Yes, I tried your suggestion already ie removed it from the board and then placed it back but COM3 was still there all the time. So that COM3 looks to be something else. No other COM ports were displayed apart from COM3.

On the other hand when I plugged that to the USB 1-4-way expander port it was displayed on my laptop in the Devices & Printers of the control panel as 802.11n USB Wireless LAN card so the USB dongle looked healthy.

My aim was to get wireless Wifi to the board.

I gave up with that USB dongle and bought the following Ethernet extender kit :

https://shop.bt.com/products/bt-broadband-extender-600-kit-084284-BVFL.html?utm_content=RR00&ReferrerID=RR00&gclid=Cj0KCQjwu8r4BRCzARIsAA21i_BrZLaLFqNJFc-ZtvrmcsUG21tbVW_CEKPqPRSUakTcR42oAQWNBUIaAq6eEALw_wcB

Managed to get that going instead :slight_smile: