Urgent Assistance Needed: PYNQ Z2 FPGA Board Boot and Connectivity Issues

Dear Xilinx Team,

I hope this message finds you well. I am reaching out to seek urgent assistance regarding persistent issues I am facing with my PYNQ Z2 FPGA board. Below, I have provided a comprehensive overview of the problem, including all relevant details:

Description of the Problem:
Upon initial setup of the PYNQ Z2 FPGA board, everything was running smoothly for the first five days. However, I am now encountering the following issues:

  1. Boot Failure:

    • Occasionally, when connecting my Asus Vivobook laptop to the PYNQ board, it fails to boot.
    • A prolonged wait results in a red LED on board near ethernet port. indicating a new Ethernet connection on the board.
    • The connection involves both direct connections: laptop to PYNQ board via Ethernet and power (from USB) directly to the laptop (from LAN to USB connector). There is no Ethernet port in my laptop. And the IP address of Ethernet is made static as mentioned in guide book.
  2. Intermittent Web Interface Issues:

    • sometimes upon successful boot, the Jupiter notebook web interface sometimes fails to open, displaying a connection timeout error.
    • This problem is exacerbated when using a dongle to access the internet from my phone’s hotspot due to restrictions on my institution’s WiFi.
    • The issue emerged since I began using the dongle, and I have configured the IP address as per the provided guide.
  3. Dongle-Related Web Interface Disruption:

    • While using the dongle connected directly to board for internet access, opening a new Jupyter notebook leads to the done light turning off, and the web interface displays a connection timeout error.
    • Disconnecting the WiFi from the laptop sometimes resolves the issue, allowing instant access to the web interface.
  • Hardware: PYNQ Z2 FPGA board, Asus Vivobook laptop.
  • Software: PYNQ software version 2.7.

Your prompt attention to this matter is greatly appreciated, as these connectivity and boot problems are hindering my work significantly. If any additional information is required, please ask.

Thank you for your assistance.

Aryan pandey

1 Like

Please reply Sir…

Hi @Aryan_Pandey,

Have you tried re flashing the SD card? SD card can get corrupted or slow over time. I suggest you use a new SD card of cat 10 or better.

Also, try using the latest image 3.0.1.


1 Like

Yes Sir, i have tried re flashing SD card with 3.0.1 image. And its a new SD card. It work well in start. Still the problem sustain.

1 Like


Can you check the output of the serial (tty terminal, micro USB on the board)?
This could give an indication of the issue.


1 Like