PYNQ: PYTHON PRODUCTIVITY

Jupyter server failed to start

I don’t know how to restart the jupyter server. Restart of the system didn’t fix my problem.
My PYNQ System works, except it can’t start my jupyter server anymore.
I am connected to my Ultra96-V2 Board logged in over the SerialPort.

I did:

hostname -I
hostname
ps aux | grep jupyter
systemctl status jupyter

grafik

Manually starting the jupyter server with these commands didn’t work:

systemctl start jupyter
jupyter-notebook
jupyter lab

Did it also happen to you? If yes do you know how to fix it?

I hope I don’t have to reinstall the PYNQ System :scream:

thank you in advance! :relaxed:

There might be more logging information if you run

journalctl -u jupyter.service

Also if you run

sudo -i
jupyter notebook

Do any error messages get printed?

Peter

Hey Peter thanks for your help!

After running

sudo -i
jupyter notebook

I got this:

I’ve also run

journalctl -u jupyter.service

Really cool that you can see all the logs with this command. Didn’t know that.
I only see a difference with these two logs. This was the output when jupyter server worked.

This is the output since it stopped working:


Do you think reinstalling jupyter would solve this issue? Or better reinstalling PYNQ ?:thinking:

Looks like this is a conflict between various versions of Jupyter/Tornado/pyzmq. There’s a thread over on the Jupyter GitHub page.

My best guess as to what’s happened is that something’s been updated and now there’s some inconsistency.

pyzmq seems to be the prime suspect so you could try sudo pip3 install -U pyzmq and see if that resolves the problem. Failing that also make sure that tornado and jupyter are up-to-date.

Note that newer versions of tornado play nicely with our implementation of interrupts if that’s important to your use-case.

Peter

Thank you soo much Peter :heart: :heart:
it works now! Thanks for your time! And I am sorry that I used your precious time to solve my issue I should have searched more and especially for the “IOLoop” “initialized”. I am sometimes a little overhelmed with the error messages and I am also never really sure whether errors are PYNQ, Jupyter or Ubuntu related error. Do you have any tipps how to trace and search for errors? Or what you do first?

I hope this Post and my Error can help other people if they encounter the same problem.

Greetings,
Noah :relaxed:

Most of it just experience to work out which part of the page or more of error message is most likely to return the most helpful google results. In general for Python/Jupyter erros it’s the last line in the stack trace that’s the most important. If it’s a line in a PYNQ file that caused the exception it’s likely our fault. Outside of the pynq python package itself though most of what gets installed comes directly from Ubuntu sources or PyPI so problems that arise with other components are likely to have been seen by people who have never heard of PYNQ.

Peter

1 Like

Ahh I understand. Thank you very much!!