PYNQ-Z2 board: There is no Linux TCF agent running : error

Hi all,

I tried to run the hello world project on Linux application, but I kept running into error “there is no Linux tcf agent running on the specified” when I tried to connect the board. Anything to check? The IP address should be correct. And I could login using SSH client. I also tried, but same error

I’m using PYNQ-Z2 board and Xilinx Vitis IDE v2020.2.0 (64-bit), and also I’m using the latest version of PYNQ for z2 board that is 3.0.1

Many thanks in advance!

HI @Mohammad_Hossein_Sam,

Welcome to the PYNQ community.
This TCF agent does not run on the board, it runs on the computer where the JTAG cable is connected.

Please, review the Vitis embedded flow.


Hi @marioruiz ,
Many thanks for your nice reply!

Based on what did I find, TCF Agent is running on both host Machine and targeted board.
As an example, It is mentioned in the following link that, "version mismatch between tcf-agent running on the target linux and Xilinx SDK (xsdk) tcf cause the error. This led the issue that XSDK couldn’t communicate to tcf-agent on the target linux with correct TCFprotocol."
another example:

And as the error is also complaining that " There is no TCF agent running on the specified IP". and the IP is (and must be) the IP of the targeted board.

So, is it TCF agent running on the PYNQ-Z2 board?

Thanks again,
Kind Regards,

Dear @Mohammad_Hossein_Sam,

Linux tcf agent agent is not enabled on the PYNQ images. If you want to try this, you should build your own image with this enabled.

However, you can develop directly on the board, gcc and g++ are part of the image.

You can also check, how to do interactive C++ development on target


1 Like